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1. Inicie o Microsoft Excel. 

Menu Start > Programs > Microsoft Excel, ou faça duplo clique no atalho Microsoft 
Excel que se encontra no ambiente de trabalho. 

2. Grave o livro de trabalho com o nome  Excel_1 

Menu File > Save, ou clique em  na barra de ferramentas 

Nota: É necessário especificar o nome do livro de trabalho na caixa de texto File name e 
o local onde se quer gravar através da caixa de seleção Save in. 

3. Na célula A1, introduza Departamento de Eng. Civil 

Selecione (clique sobre) a  célula A1 
Digite   Departamento de Eng. Civil +  Enter 

4. Na célula A2, introduza   Resumo de Alunos Finalistas. 

5. Na linha 4, introduza o texto apresentado em cada uma das seguintes colunas: 
A –   Curso 
B –   Diurnos 
C –   Noturnos 
D –   Nº Turmas 
E –   Total Diplomados 
Selecione o bloco de células onde irá introduzir os dados, arrastando o indicador do rato 
desde a célula  A4  até à célula  E4; 
Digite cada texto acima apresentado premindo Enter, para passar para a próxima célula 
na seleção. 

Notas:  Shift + Enter  permite-lhe inverter o sentido da introdução de dados. 
Para anular uma seleção, basta fazer clique com o rato em qualquer local da 
folha de cálculo ou premir qualquer uma das teclas de direção.  

6. Introduza o texto e os valores nas células de modo a que a sua folha fique igual à que a 
seguir se apresenta: 

 
Nota: Atendendo a que os valores dos totais de diplomados são iguais para os 3 cursos 

(12), basta introduzir o 1º valor na célula E5 e copiá-lo para as células  E6  e  E7, 
arrastando o indicador de preenchimento (quadrado no canto inferior direito da 
célula). 
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7. Os dados que acabou de introduzir referem-se ao ano de 2007. Insira uma nova linha 
entre a 3ª e a 4ª linha onde conste essa indicação, tal como a seguir se apresenta: 

 

Utilizando a barra de cabeçalho de linhas, selecione a linha 4 
Menu Insert > Rows 

8. Na introdução dos dados foi cometido um erro de digitação no Total de Diplomados do 
curso de Licenciatura em Engenharia Civil. Sabendo que o valor correto é  36, efetue a 
alteração. 

Selecione a célula E6 ou faça um duplo clique sobre a célula E6. Neste caso, o cursor 
surge intermitente no interior da célula, o que permite apagar o valor; 
Digite o novo valor  +  Enter 

9. Pretende-se obter uma nova coluna que apresente o total de alunos por curso. Insira-a 
entre as colunas  C  e  D  e dê-lhe o título Total Alunos. 

Utilizando a barra de cabeçalho de colunas, selecione a coluna D 
Menu Insert > Columns 

10. Ajuste a largura das colunas, automaticamente ou manualmente, de modo que todos os 
títulos sejam completamente visíveis. 

Mova o indicador do rato sobre a barra de cabeçalho de colunas, na coluna que deseja 
ajustar, até que este se transforme numa dupla seta. 

Arraste e defina manualmente a largura de coluna pretendida, ou faça duplo clique 
para ajustar automaticamente a largura da coluna. 

11. Na célula D6, introduza a fórmula que lhe permita calcular o total de alunos no curso de 
Licenciatura Engenharia Civil. 

Selecione a célula:  D6 
Digite:    =B6 + C6 
Pressione a tecla:   Enter  

12. Copie a fórmula para as células D7 e D8 de modo a obter o total de alunos nos cursos de 
Mestrado Engenharia Civil Tecnologia e Gestão das Construções. 

Arraste o indicador de preenchimento da célula  D6  para  D7  e  D8. 



Microsoft Excel  Exercício 1 
 

Conceitos Básicos  Pág. 3/6 
 

13. Na célula D9, introduza a fórmula que permite determinar o total de alunos finalistas nos 
3 cursos. Identifique este total, introduzindo em C9   Tot. Geral. 

14. Pretende-se uma nova coluna que apresente a média de alunos por turma. Insira-a entre 
as colunas E e F e dê-lhe o título Média Alunos/Turma. 

15. Na célula F6, introduza a fórmula que lhe permita obter a média de alunos por turma no 
curso de Licenciatura Engenharia Civil. 

16. Copie a fórmula para as células F7 e F8 de modo a obter a média de alunos por turma 
nos cursos de Mestrado Engenharia Civil e Tecnologia e Gestão das Construções. 

17. Mova o título e subtítulo que se encontram no bloco de células A1:A2 para D1:D2 

Selecione o bloco de células  A1:A2 

Menu Edit > Cut, ou clique em  na barra de ferramentas 
Selecione a célula  D1 

Menu Edit > Paste, ou clique em  na barra de ferramentas 

18. Mova o bloco A4:B4 para D4:E4. O aspeto da sua folha de cálculo deverá ser: 

 

19. Altere o nome da 1ª folha (Sheet1) para Resumo de Finalistas. 

Duplo clique sobre o separador da folha 
Digite    Resumo de Finalistas  +  Enter 

20. Atendendo a que as outras folhas não se mostram necessárias, elimine-as. 

Clique sobre o separador de uma das folhas a eliminar 
Pressione a tecla Ctrl enquanto faz clique no separador da outra folha a eliminar 
Menu Edit > Delete sheet 

21. Pretende-se efetuar um mapa similar para o ano de 2006. Como base pode utilizar-se 
uma cópia da tabela anteriormente elaborada, efetuando-se depois as necessárias 
alterações aos valores. O canto superior esquerdo da nova tabela deverá situar-se na 
célula A12 e apresenta-se de seguida os valores para as diferentes células:  
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Selecione o bloco de células  A1:G9 

Menu Edit > Copy, ou clique em  na barra de ferramentas 

Selecione a célula A12 

Menu Edit > Paste, ou clique em  na barra de ferramentas 

Pressione a tecla Escape (Esc) para cancelar a seleção do bloco A1:G9  

22. De modo a analisar mais cuidadosamente a evolução do curso de Licenciatura 
Engenharia Civil entre os anos de 2006 e 2007, oculte as linhas relativas aos outros 
cursos (7, 8, 18 e 19). 

Utilizando a barra de cabeçalho de linhas e por arrastamento selecione as linhas 7 e 8 
Pressione a tecla Ctrl enquanto seleciona por arrastamento as linhas 18 e 19 
Menu Format > Row > Hide 

23. Visualize completamente as duas tabelas, mostrando todas as linhas ocultadas no ponto 
anterior. 

Selecione as linhas  6 a 9  e  17 a 20  utilizando a barra de cabeçalho de linhas 
Menu Format > Row > Unhide 

24. Pretende-se analisar a distribuição do número total de alunos pelas turmas nos 3 cursos 
nos 2 anos considerados. Oculte as colunas B, C e G uma vez que não se mostram 
necessárias para este tipo de análise. 

Utilizando a barra de cabeçalho de colunas selecione por arrastamento as colunas B e C 
Pressione a tecla  Ctrl  enquanto seleciona a coluna G 
Menu Format > Column > Hide 

25. Visualize novamente todos os dados que se encontram nas duas tabelas, mostrando todas 
as colunas ocultadas no ponto anterior. 

Selecione as colunas A a D  e  F a H utilizando a barra de seleção de colunas 
Menu Format > Column > Unhide 

26. Atendendo a que se pretende introduzir também os dados referentes ao ano de 2008, 
entende-se que a melhor organização é colocar em folhas separadas os dados referentes 
aos finalistas de cada ano. Sendo assim, insira uma nova folha e altere o seu nome para 
Finalistas 2006. 

Menu Insert > Worksheet 
Duplo clique sobre o separador da folha 

Digite     Finalistas 2006  +  Enter. 
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27. Copie o título e subtítulo da folha Resumo de Finalistas para a folha Finalistas 2006. 

Selecione o bloco de células  D1:D2 

Menu Edit > Copy, ou clique em  na barra de ferramentas 

Clique sobre o separador da folha Finalistas 2006 para mudar para esta folha 

Selecione a célula  D1 

Menu Edit > Paste, ou clique em  na barra de ferramentas.  

28. Mova os dados referentes ao ano de 2006 da folha Resumo de Finalistas para a folha 
Finalistas 2006. 

Selecione o bloco de células  A15:G20  na folha Resumo de Finalistas 

Menu Edit > Cut, ou clique em  na barra de ferramentas 

Mude para a folha  Finalistas 2006 

Selecione a célula  A4 

Menu Edit > Paste, ou clique em  na barra de ferramentas.  

29. Elimine as linhas 12 e 13 da folha Resumo de Finalistas. 

Selecione as  linhas 12 e 13  na barra de cabeçalho de linhas 
Menu Edit > Delete 

30. Efetue os ajustamentos necessários à largura das colunas de modo a que se visualizem 
completamente todos os títulos na folha Finalistas 2006. 

31. Altere o nome da folha  Resumo de Finalistas  para  Finalistas 2007. 

32. Efetue uma cópia da folha Finalistas 2007 e coloque-a antes desta, alterando o seu nome 
para   Finalistas 2008. 

Menu Edit > Move or Copy Sheet 
Selecionar Finalistas 2007 na caixa de listagem  Before sheet 
Selecionar a opção  Create a copy. 

33. Atendendo a que o curso de Tecnologia e Gestão das Construções deixou de funcionar, 
elimine a linha correspondente na folha Finalistas 2008 e efetue a necessária correção à 
fórmula que calcula o total geral de alunos finalistas nos 2 cursos. 

34. Considerando que ainda não são conhecidos os dados relativos aos diplomados do ano de 
2008, apague os dados que constam nessa coluna. Altere todos os outros valores de modo 
a que fiquem iguais aos que a seguir se apresentam: 
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Selecione o bloco de células  G6:G7 
Pressione a tecla Delete 

 

35. Movendo as folhas, coloque-as pela seguinte ordem: Finalistas 2006, Finalistas 2007 e 
Finalistas 2008. 

Selecione o separador da folha pretendida 
Arraste-o sobre a área de seleção da folha para a posição pretendida. O triângulo preto 
indica onde será inserida a folha se largar o botão do rato.  

36. Grave e feche o livro de trabalho Excel_1. 

Menu File > Save, ou clique em  na barra de ferramentas 

Menu File > Close, ou clique em  na barra de menus. 

37. Crie um novo livro de trabalho em branco para realizar o seu próximo trabalho. 

Menu File > New, ou clique em  na barra de ferramentas. 

38. Na folha Finalistas 2008 do livro de trabalho Excel_1, por lapso não foi alterado o ano na 
célula E4. Abra o livro de trabalho e efetue a correção. 

Menu File > Open, ou clique em  na barra de ferramentas. 

Notas: É necessário especificar o nome do livro de trabalho na caixa de texto File name 
e o local onde este se encontra gravado através da caixa de seleção Look in. 
Uma forma rápida de abrir um livro em que recentemente se esteve a trabalhar, 
é utilizando a lista de livros recentes que se encontra no fim do menu file: 

39. Grave e saia do Excel. 

Menu File > Save, ou clique em  na barra de ferramentas; 

Menu File > Exit, ou clique em  na barra de título.
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O objetivo deste livro de trabalho é ajudar a sua empresa no controle das Existências e das 
Vendas efetuadas. No final da aula, deve ter um livro de trabalho semelhante ao apresentado 
na última página. 

1. Inicie o Microsoft Excel. 

2. Grave o livro de trabalho com o nome Excel_2 

3. Na célula C1 da folha 1 (sheet 1) introduza:  Existências em Armazém 

4. Formate a célula C1 com: Font=Arial;  Size=16;  Style=Bold Italic;  Color=Dark Red 

Menu Format > Cells... > Font 

5. Na célula F1 introduza:  Data 

6. Aplique a formatação da célula C1 à célula F1, mas com exceção do font size=12. 

Selecione a célula C1 

Selecione o botão Format Painter  para copiar a formatação da célula C1 
Selecione a célula F1 
Altere o tamanho da letra para 12 
NOTA: para eliminar uma formatação: Menu Edit > Clear > Formats 

7. Na linha 3 preencha os dados conforme a figura apresentada na página seguinte. 

8. Na célula H1 insira a data atual, recorrendo ao assistente de funções.  

Separador Formulas > Insert Function 
Selecione a categoria Date&Time 
Selecione a função Today     ( A data não irá coincidir obviamente com a da figura! ) 

9. Formate a data anterior de acordo com o exemplo dado. 

Menu Format > Cells...>Number > Category=Custom > Type=dd/mm/yy (ou 
dd/mm/aa) 

10. Insira, por sequência, as referências dos produtos nas células A4:A12. 

Preencha a célula A4 com o valor 100 
Coloque o rato no canto inferior direito da célula até aparecer o sinal +  
Com o botão direito pressionado, arraste o rato até à célula A12  
Liberte o botão direito do rato e escolha a opção Fill Serie 

11. Prossiga a construção da folha de existências, preenchendo as células do bloco  B4:E12  
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12. Preencha as células do bloco  F4:F12  da maneira descrita a seguir. 

Preencha a célula  F4  
Copie o conteúdo da célula F4 para as células  F5:F7 
Preencha a célula F8 
Selecione as células F7:F8  
Coloque o rato no canto inferior direito do bloco selecionado   
Com o botão esquerdo pressionado, arraste o rato até à célula F12 

 

13. Preencha os blocos G4:G12 e I4:I12, de acordo com o exemplo dado. 

14. Crie as fórmulas adequadas nas células H4:H12, por forma a que estas apresentem o 
valor das existências de cada artigo em armazém. 

Selecione a célula H4 
Usando o rato, crie a seguinte fórmula:    =E4*G4   
Copie a fórmula para as células seguintes  H5:H12 

 

15. Ainda relativamente à formatação da sua tabela, deve formatar todos os campos 
monetários para aparecerem como na primeira figura apresentada na última página. 

Usando a tecla Control (CTRL), selecione simultaneamente, os blocos E4:E12 e 
H4:H12 
Com o botão direito do rato sobre a área sombreada, escolha a opção Format Cells ou 
então Menu Format > Cells 
Na folha Number escolha a categoria Currency e o símbolo Euro (€). 

16. Todas as células do bloco F4:F12, devem ser formatadas com o tipo  dd/mm/yyyy  (ou 
dd/mm/aaaa). 

17. Antes de inserir as fórmulas que são pedidas nos pontos seguintes, introduza nas células 
D19, D21, D22, D24, D26, D27 e D29, as descrições correspondentes, conforme 
constam na primeira figura da última página. Deve ter em atenção o alinhamento à 
direita do texto a inserir. 
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18. Para que o diretor tenha a informação do valor total dos produtos em armazém, comece 
por criar uma fórmula adequada na célula E19, usando a função Sum. 

Selecione a célula E19 

Selecione o botão AutoSum  
Selecione o bloco H4:H12 
Pressione a tecla Enter. 

19. É também do interesse do diretor, saber quantos artigos distintos tem no armazém. 
Portanto, coloque essa informação na célula E21. 

Selecione a célula E21 
Menu Insert > Function 
Selecione a categoria Statistical e o nome da função Count 
Selecione, com o rato, o conjunto de células que quer contar: A4:A12 

NOTA: a função Count só conta números. Para utilizar, por exemplo, o bloco de células 
B4:B12, utilize a função CountA. 

20. Uma outra informação importante para o diretor é a existência média por artigo. Coloque 
essa informação na célula E24. 

Selecione a célula E24 
Menu Insert > Function 
Selecione a categoria Statistical e o nome da função Average 
Selecione, com o rato, o conjunto de células para as quais quer determinar a média: 
G4:G12. Apresente o valor calculado, formatado com 0 (zero) casas decimais. 

21. Para facilitar o trabalho na manutenção das existências de cada artigo, deve aparecer na 
coluna J  a indicação,  “A Requisitar”,  sempre que haja rotura de stock, i.e., sempre que 
as quantidades em stock sejam inferiores às da existência mínima. 

Selecione a célula J4 
Menu Insert > Function 
Selecione a categoria Logical e o nome da função  If 
Na 1ª linha da caixa de diálogo indique o Logical_Test (condição):  G4<I4 
Na 2ª linha indique o valor a colocar na célula quando a condição é verdadeira: “A 
Requisitar” 
Na 3ª linha indique o valor a colocar na célula quando a condição é falsa: “” 

22. Copie a fórmula anterior para as células J5:J12. 

23. Para que seja possível saber quantos artigos estão em falta (à espera de serem 
requisitados), deve ser apresentada essa informação. 

Selecione a célula E22 
Menu Insert > Function 
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Selecione a categoria Statistical e o nome da função CountIf 
No campo Range indique as células J4:J12, selecionando-as com o rato 
No campo Criteria indique o critério de contagem: ”A Requisitar”. 

24. Para que tenham em linha de conta as datas de validade dos preços, deve construir uma 
fórmula na célula E26 e outra na célula E27, para determinar a data de validade mais 
recente e mais antiga, respetivamente. 

Selecione a célula E26 
Menu Insert > Function 
Selecione a categoria Statistical e o nome da função Max 
Com o rato selecione o conjunto de células F4:F12 
Repita os passos anteriores para a célula E27 e use a função Min 

25. Para que a folha tenha um aspeto mais profissional, deve formatá-la com o estilo List 1. 

Selecione o bloco A3:J12 
Menu Home > Format as Table 
Escolha o estilo Table Style Light 1 

26. Apesar dos dados da folha de cálculo estarem acompanhados duma breve descrição, 
ainda há dados pouco percetíveis. Nestes casos, devemos adicionar comentários. 

Selecione a célula J3 
Menu Review > New Comment 
Introduza, por exemplo:  A requisitar quando há rutura de stock 
Para visualizar o comentário, basta posicionar o rato sobre a célula que possui o 
comentário. 

27. Para terminar a composição desta folha, deve verificar se é necessário ajustar o tamanho 
de alguma coluna e se a folha está de acordo com o exemplo dado. 

28. Pretendemos agora analisar, unicamente, a Existência Mínima dos artigos, mas como esta 
coluna está muito à direita na folha, essa análise não é fácil. Para ultrapassar esta 
dificuldade, deve fixar a coluna A e as linhas acima da linha 4. 

Selecione a célula B4 
Menu View > Freeze Panes 
Desloque a folha de cálculo para a direita ou para baixo, e repare que há células fixas. 

29. Altere o nome da folha 1 para Existências. 

30. Elimine a folha 3. 

31. Altere o nome da folha 2 para Vendas fevereiro. Esta folha vai conter informação sobre 
os artigos vendidos durante o mês de fevereiro. 

32. Na folha Vendas fevereiro preencha a célula E1 de acordo com o exemplo dado (2ª figura 
da última página) e aplique a formatação da célula C1 da folha Existências. 
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33. Na folha Vendas fevereiro preencha as células A2 e B2 com a taxa de IVA. 

34. Preencha toda a linha 3. Repare que parte dela, é uma cópia da linha 3 da folha 
Existências e assim sendo, proceda à sua cópia. 

35. Para facilitar o trabalho do colega que efetua as vendas, a introdução de dados deve ser o 
mais automatizada possível. Dos dados necessários, o vendedor apenas precisa de 
introduzir, manualmente, o nº de Cliente e a Quantidade de unidades. Os restantes 
dados (Referência do Artigo, Descrição, Classe, U.M. e Preço Unitário) podem ser 
introduzidos automaticamente, uma vez que se encontram guardados na folha 
Existências. Para isso, o vendedor tem de criar as fórmulas adequadas nas células 
correspondentes. 

Nas células A4:A6 insira os números de Cliente, de acordo com o exemplo dado  
Na célula B4 insira a fórmula:  = Existências!A5  

Digite   = 
Selecione o separador da folha Existências 
Selecione A5    e  carregue na tecla Enter 

Copie esta fórmula para as células B5:B6 e depois para as células C4:F6.  

36. Na coluna G deve ser calculado, automaticamente, o valor de IVA por Unidade (deve 
utilizar sempre a taxa de IVA indicada na célula B2). 

Na célula G4 crie a fórmula: =F4*$B$2 
(Use a tecla F4 para introduzir o $) 

Copie a fórmula anterior para as células G5:G6 e verifique se os cálculos estão corretos. 

37. Para completar a introdução da venda, deve preencher a coluna H com o número de 
unidades vendidas (conforme a figura respetiva) e a coluna I com fórmulas para calcular 
o valor a faturar. 

38. Formate a tabela com o estilo Table Style Light 1 e os valores monetários com o formato 
adequado. 

39. Por último, pretende-se calcular o total faturado no mês, o valor da maior fatura, o 
valor da menor fatura e o valor médio por fatura. Nesse sentido, deve introduzir as 
fórmulas adequadas nas células indicadas no exemplo dado. 

40. Como todos os meses tem de existir uma folha de vendas, é altura de preparar a de 
março. Para isso, insira uma folha nova, efetue uma cópia da folha Vendas fevereiro e 
faça as alterações de acordo com o exemplo dado. 
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41. Todos os meses o seu diretor verifica se não foram cometidos erros nas folhas de vendas, 
mas para não se confundir, pediu-lhe para ocultar todas as outras folhas, com exceção 
da folha Vendas de fevereiro. 

Menu Format > Sheet > Hide. 

42. Após a verificação das Vendas de fevereiro, deve mostrar novamente todas as folhas. 

43. Para terminar, insira na célula E29 da folha Existências, o total faturado nos meses de 
fevereiro e março e aplique a correspondente formatação. 

Figuras: 
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1. Numa folha de Excel introduza os seguintes dados: 

 A B C D E F G 
1  1º Trim. 2º Trim. 3º Trim. 4º Trim. Total % 
2 Vendas 100000 120000 140000    
3 Custos 35000 50000 60000    
4 LUCRO BRUTO       
5 Despesas:       
6 Salários 25000 25000 25000    
7 Despesas gerais 3750 4000 5000    
8 Distribuição 5000 6000 7000    
9 Impostos       

10 TOTAL DESPESAS       
11 LUCRO       

2. Grave o livro de trabalho com o nome Excel_3. 

3. Preencha os valores relativamente ao  4º trimestre,  sabendo que:  
a) As vendas aumentaram 12% relativamente ao 3º trimestre (soluções na última 

página). 
b) Os custos foram de 85.000 €. 
c) Os salários  diminuíram 5%  relativamente ao trimestre anterior. 
d) As despesas gerais foram iguais à média dos  3 trimestres  anteriores. 
e) Os custos de distribuição representam  5%  das vendas. 
f) Os impostos (no 4º trimestre) representam 10%  do valor das vendas. 
g) Complete as células referentes aos totais (coluna F). 

4. Nas células B9:D9 crie fórmulas para calcular os impostos nos 3 primeiros trimestres do 
ano, sabendo que, em cada mês, correspondem a 10%  das vendas efetuadas. 

5. Complete as linhas  4,  10  e  11. Sabe-se que: 

a) Lucro Bruto = Vendas - Custos 
b) Total Despesas = Salários + Desp. Gerais + Distribuição + Impostos 
c) Lucro = Lucro Bruto - Total Despesas 

6. Formate as células da tabela da seguinte forma: 

a) Todos os carateres deverão ser do estilo Times New Roman com tamanho 10 
b) Ajuste a largura da coluna A à largura do texto 
c) A largura das colunas B, C, D, E e F deverá ser de 11 (Menu Format> Column> 

Width=11) 
d) Na linha 1 de cabeçalho, o texto deverá ter o tamanho 12, estar centrado e em 

bold 
e) Os valores numéricos (colunas B, C, D, E e F) deverão ser formatados de modo a 

apresentarem o separador dos milhares, duas casas decimais e o símbolo de euro. 
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f) Todos os dados das linhas   4, 10 e 11  deverão estar em bold 
g) Altere o nome da folha em que está a trabalhar para “Vendas”. 

7. Selecione as células A13, A14, A15 e A16 e escreva, respeitando os formatos 
apresentados na figura da última página,  Vendas:, Valor Médio, Valor Máximo e Valor 
Mínimo, respetivamente. Introduza as fórmulas correspondentes (relativas aos 4 
trimestres das Vendas) nas células  B14,  B15  e  B16. 

8. Calcule em G3 o peso dos custos e em G6:G9 o peso de cada uma das 4 despesas, 
relativamente ao total de vendas.  Formate estas 5 células como percentagem e com 
duas casas decimais. 

Home > Format > Cells...> Number > Category = Percentage > Decimal Places = 2 

9. Formatação de limites e sombreados da tabela.  Selecione a área  A1:G11  e  faça:   
Home > Format > Cells… > Border > Style … 

a) Em Style escolha um risco fino e carregue em  Presets > Inside  ficando a tabela 
com linhas verticais e horizontais finas 

b) Ainda em Style, escolha um risco largo para o contorno exterior da tabela, 
carregando em  Presets > Outline.  Faça  OK. 

c) Formate as células referentes ao Lucro Bruto, Total Despesas e Lucro com a cor 
de fundo cinzenta (Selecione as áreas  A4:G4, A10:G10 e A11:G11  
simultaneamente) 

Home > Format > Format Cell > Fill > Pattern Color = cinza claro.   OK. 

10. Altere o nome da folha 2 para Vendedores. 

11.  Na folha Vendedores introduza os seguintes dados: 
 A B C D E F G H 

1  Vendas    
2 Nome dos Vendedores 1º Trim. 2º Trim. 3º Trim. 4º Trim. Total Bónus % 
3 Daniela Ferraz 12.900,00€ 19.000,00€ 27.500,00€ 20.050,00€    
4 Sónia Costa 40.000,00€ 39.850,00€ 48.000,00€ 49.150,00€    
5 João Ramos 9.600,00€ 17.900,00€ 21.500,00€ 35.050,00€    
6 Pedro Dias 37.500,00€ 43.600,00€ 43.350,00€ 52.550,00€    
7 Totais          

a) O título Vendas deverá ser introduzido na célula A1,  ficar centrado ao longo da 
área da tabela  (A1:H1)  e em bold.  Para abranger a área pedida, faça: 

Menu Format > Cells… > Alignment > Text Control = Merge Cells 

b) Na linha 2 o texto também deve ficar centrado e em bold. 

c) Os dados numéricos da área  (B3:G7)  devem deverão ser formatados de modo a 
apresentarem o separador dos milhares e o símbolo de euro. 
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d) Na célula A7 o texto deverá ser a bold e alinhado à direita. 

e) Calcule os totais das vendas por trimestre e por vendedor e formate-os a bold. 
Selecione simultaneamente as áreas  F3:F6 e  B7:F7 
Carregue no botão de  AutoSum 

f) Escreva  Bónus  na célula G10,  e   5%   na célula H10. 

12. Selecione os dados e os nomes dos vendedores da tabela (A2:F6) e ordene por ordem 
alfabética e de forma ascendente de nomes, mantendo assim a correspondência dos 
valores já inseridos. 

Menu Data > Sort > Sort by = Nome dos Vendedores  

13. É atribuído um bónus de 5% aos vendedores com vendas totais superiores a 125.000€. 
Preencha as células G3:G6 com fórmulas que utilizem a célula H10 como endereço misto 
(H$10), e atribuam o valor 0 (zero) aos vendedores não bonificados. 

14. Na coluna H, determine o peso das vendas de cada vendedor no total das vendas da 
empresa, utilizando a fórmula com endereço absoluto ($F$7). Altere a coluna utilizando o 
formato de percentagem com 2 casas decimais. 

Nota: se o ícones relativos ao AutoFormat e aos formulários (Form) não estiverem 
disponíveis na Quick Access Toolbar                                                   faça: 

a) Aceda ao Office Button             e a Excel Options  

b) Selecione Customize, All Commands 

c) Procure o símbolo de AutoFormat, selecione e faça Add 

d) Repita o procedimento anterior para o Form  

15. Numa nova folha do Excel, que deve ter o nome Despesas, preencha as células A1:F1 
com os seguintes títulos: Vendedor, Trimestre, Alojamento, Gasolina, Outros e Total. 

Selecione a área A1:E9 e recorrendo a um formulário introduza os dados na tabela. 

Introduza na coluna F as fórmulas que permitem calcular o valor Total para cada 
vendedor. Formate em seguida a tabela com AutoFormat > Classic 3 

 A B C D E F 
1      Vendedor Trimestre Alojamento Gasolina Outros Total 
2   Pedro Dias 1º 375,00€ 140,00€ 60,00€ 575,00€ 
3   Sónia Costa 1º 400,00€ 235,00€ 240,00€ 875,00€ 
4   Daniela Ferraz 2º 425,00€ 115,00€ 64,00€ 605,00€ 
5   João Ramos 2º 425,00€ 181,00€ 325,00€ 931,00€ 
6   Sónia Costa 2º 375,00€ 330,00€ 255,00€ 960,00€ 
7   Pedro Dias 2º 500,00€ 195,00€ 125,00€ 820,00€ 
8   João Ramos 1º 525,00€ 315,00€ 175,00€ 1015,00€ 
9   Daniela Ferraz 1º 490,00€ 270,00€ 390,00€ 1150,00€ 
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16. Posicione-se numa das células da tabela e ordene os dados por Vendedor e por 
Trimestre. 
 Menu Data > Sort   
 

 
 

 A B C D E F 
1      Vendedor Trimestre Alojamento Gasolina Outros Total 
2   Daniela Ferraz 1º 490,00€ 270,00€ 390,00€ 1150,00€ 
3   Daniela Ferraz 2º 425,00€ 115,00€ 64,00€ 604,00€ 
4   João Ramos 1º 525,00€ 315,00€ 175,00€ 1015,00€ 
5   João Ramos 2º 425,00€ 181,00€ 325,00€ 931,00€ 
6   Pedro Dias 1º 375,00€ 140,00€ 60,00€ 575,00€ 
7   Pedro Dias 2º 500,00€ 195,00€ 125,00€ 820,00€ 
8   Sónia Costa 1º 400,00€ 235,00€ 240,00€ 875,00€ 
9   Sónia Costa 2º 375,00€ 330,00€ 255,00€ 960,00€ 

 

17. Introduza um filtro na tabela de forma a obter os dados dos vendedores que 
apresentaram despesas totais superiores a  1000 €. 

Selecione uma célula da tabela 
 Menu Data > Filter 

Carregue na seta:   Total  > Number Filters > Custom Filter 
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Vendedor Trimestre Alojamento Gasolina Outros Total 
  Daniela Ferraz 1º 490,00€ 270,00€ 390,00€ 1150,00€ 
  João Ramos 1º 525,00€ 315,00€ 175,00€ 1015,00€ 
  

18. Pretende-se saber quais os dois vendedores que apresentaram menores despesas. 
Carregue na seta:   Total        >  (Top 10...) 

 
Vendedor Trimestre Alojamento Gasolina Outros Total 

  Daniela Ferraz 2º 425,00€ 115,00€ 64,00€ 604,00€ 
  Pedro Dias 1º 375,00€ 140,00€ 60,00€ 575,00€ 
 

19. Retire todos os filtros da tabela     Menu Data > Filter 

20.  Pretende-se que sejam apresentados subtotais do valor das Despesas Totais, por 
Trimestre. 

Para efetuar esta operação deve posicionar-se numa das células da tabela e ordenar por 
Trimestre. 

 
Nos subtotais, introduza somatórios na coluna Total. Menu Data >  Subtotal ... 
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1       Vendedor Trimestre Alojamento Gasolina Outros Total 
2   Daniela Ferraz 1º 490,00€ 270,00€ 390,00€ 1.150,00€ 
3   João Ramos 1º 525,00€ 315,00€ 175,00€ 1.015,00€ 
4   Pedro Dias 1º 375,00€ 140,00€ 60,00€ 575,00€ 
5   Sónia Costa 1º 400,00€ 235,00€ 240,00€ 875,00€ 
6     1º Total    3.615,00€ 
8   Daniela Ferraz 2º 425,00€ 115,00€ 64,00€ 604,00€ 
7   João Ramos 2º 425,00€ 181,00€ 325,00€ 931,00€ 
9   Pedro Dias 2º 500,00€ 195,00€ 125,00€ 820,00€ 
10   Sónia Costa 2º 375,00€ 330,00€ 255,00€ 960,00€ 
11  2º Total    3.315,00€ 
12  Grand Total    6.930,00€ 

21. Esconda os dados dos vendedores, deixando apenas visíveis os totais por trimestre e o 

global. Pressione com o rato na caixa lateral (sinal  +  ou  – ), referente a cada um dos 

subtotais. 

Vendedor Trimestre Alojamento Gasolina Outros Total 
   1º Total    3.615,00€ 
   2º Total    3.315,00€ 
    Grand Total    6.930,00€ 

 
Soluções: 
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22. Abra o ficheiro de trabalho Excel_3a.xls 

23. Selecione a folha Notas1  e preencha a célula  I3  sabendo que a avaliação prática 
representa  60% da nota final,  sendo os restantes   40%  para qualquer um dos exames.  

Após criar a fórmula em  I3  arraste-a para as restantes células. 

Nota:  deve,  em  primeiro lugar,  verificar se o exame de recurso  foi  efetuado ou não   

=IF( H3< >”” ;    .  .  .   ) 

Se a condição se verificar, a média é feita com a nota do recurso ( H3 ), caso 
contrário será com a nota do exame  em  ( G3 ).  

24. Na coluna J crie uma fórmula que calcule a situação final do aluno, APROVADO ou 
REPROVADO consoante a nota final. O aluno é Reprovado se obtiver Nota Final inferior a  
9.5 

Nota:  Antes de copiar a fórmula de J3 para as restantes células  J4:J32   pretende-se 
que a palavra  REPROVADO apareça escrita a vermelho;  para o efeito, posicione-
se em J3 e faça: 

 
Home  >  Conditional Formatting  > New Rule > Format only cells that contain 

Selecione as opções de acordo com a figura 
  A seguir carregue em Format 
  Selecione a cor pretendida 
  Faça   Ok 
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25. O conjunto das células F3:H32 deverão ser validadas para que só admitam valores 
pertencentes ao intervalo [0;20], de modo a que se o utilizador tentar introduzir valores que 
não pertençam ao intervalo referido apareça uma caixa de erro, informando quais os valores 
permitidos. 

 Selecione  F3:H32  e faça:  

 Data >  Data Validation >  Settings 
Preencha de acordo com a figura,  mas  sem carregar ainda em OK 

 
De seguida carregue no separador   Error Alert 
Preencha de modo a obter uma caixa de mensagem de erro de acordo com a figura. 

26. As células da coluna C devem estar validadas para aceitar apenas as letras M  ou  F.  
Selecione  C3:C32  e faça: 

  Data >  Data Validation >  Settings  e preencha: 
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27. Preencha as  células I34, I35 e I36 utilizando as funções  Count( )  e  CountIF( ). 

 

Nº Total de Alunos: 30 
Nº de Aprovados: 24 

Nº de Reprovados: 6 
 

28. Utilizando a função SUMIF() construa uma fórmula na célula I37 que forneça a 
quantidade total de faltas dadas pelos alunos reprovados. O resultado previsto é 46. 

 

29. Na folha de cálculo Pesquisa, insira nas células C8 e C10 as fórmulas que forneçam a 
informação de qual a Nota e Situação, respectivamente, do aluno cujo número tiver sido 
inserido na célula C6. Sugestão: utilize a função VLOOKUP. 





 

 

Excel 4 – Formatações e Gráficos 
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Pretende-se criar um livro de trabalho para guardar e analisar os dados relativos às vendas 
efetuadas no ano de 2010, pelo stand de automóveis Auto, Lda. Nesse sentido, siga os 
seguintes passos: 
 
1. Iniciar o Microsoft Excel. 

2. Abrir o livro de trabalho com o nome  Excel_4a.xls. 

3. Guardar uma cópia do livro  Excel_4a.xls  na sua pasta pessoal com o nome Excel_4.xls. 

4. Selecionar a folha  Resultados 2010. 

5. Formatar todos os dados numéricos da área  (C4:G8) de modo a apresentarem o 
separador dos milhares, o símbolo de euro e não apresentando qualquer casa decimal. 

6. Iniciar a formatação da tabela  Vendas, centrando o título Vendas entre as colunas B e G. 
a) Selecionar o bloco de células  B2:G2 
b) Premir o botão  Merge and Center       no separador Home. 

7. Formatação de limites 
a) Selecionar o bloco de células  B2:G8 
b) Home > Format > Cells > Border 
c) Selecionar um traço grosso 
d) Selecionar  Presets Outline 
e) Selecionar um traço fino 
f) Selecionar  Presets Inside 
g) Premir o botão  OK 

 

h) Selecionar o bloco de células  B3:G3 
i) Home > Format > Cells > Border 
j) Selecionar um  traço grosso 
k) Selecionar  Presets Outline 
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8. Formatação de sombreados 
a) Selecionar a célula  B2  e o bloco  B3:B8 
b) Home > Format > Cells > Fill 
c) Selecionar uma cor cinzenta 

 
9. Mostrar múltiplas linhas de texto dentro duma célula 

a) Selecionar o bloco de células  B3:G3 
b) Home > Format > Format Cells > Alignment 
c) Selecionar a caixa de verificação  Wrap Text 
d) Selecionar  Center  na caixa Vertical e Horizontal, para que o texto apareça 

centrado 
e) Premir o botão  OK 
f) Alterar a largura das colunas  C,  D,  E  e  F  e aumentar a altura da linha 3, 

de modo a obter um formato semelhante à da figura seguinte: 

 
 

10. Preencher as células vazias. 

a) Introduzir na célula C8 uma fórmula para calcular o total de vendas efetuadas no 1º 
trimestre. Utilizar o botão AutoSum       do separador  Formulas. 

b) Copiar a célula C8 para o bloco de células  D8:F8 
c) Introduzir na célula G4 uma fórmula para calcular o total de vendas anual efetuadas 

pelo vendedor  Paulo Sousa 
d) Copiar a célula  G4  para o bloco de células  G5:G8 
e) Formatar as céclulas da linha 8 de forma semelhante à apresentada na imagem. 
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11. No final de cada ano, a administração do stand faz um balanço da sua atividade, e é 
costume comparar os desempenhos de cada um dos seus vendedores. Para facilitar essa 
comparação, deve-se criar um gráfico de colunas. 

a) Selecionar os blocos de células B4:B7 e G4:G7 

b) Selecionar o separador Insert 

c) Selecionar Column > Clustered Column 

 
d) Selecionar separador Layout 
e) Inserir o título do gráfico 

• Selecionar Chart Title > Above Chart 

• Modificar o texto “Chart Title” para “Vendas” 
f) Inserir o título do eixo dos XX 

• Selecionar Axis Titles > Primary Horizontal Axis Titles > Title Below Axis 

• Modificar o texto “Axis Title” para “Vendedores” 
g) Inserir o título do eixo dos YY 

• Selecionar Axis Titles > Primary Vertical Axis Titles > Rotated Title 
Modificar o texto “Chart Title” para “Total” 

h) No sentido de eliminar a legenda, selecionar Legend > None 

 
i) Mover o gráfico para baixo da tabela 

I. Selecionar o gráfico, fazendo clique numa área vazia do fundo do gráfico (Chart 
Area) 

II. Arrastar o rato com o botão esquerdo premido 
j) Alterar a dimensão do gráfico para ocupar o bloco de células  B10:G25 

I. Selecionar o gráfico fazendo clique numa área vazia do fundo do gráfico Chart 
Area 
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II. Arrastar as alças (quadradinhos pretos que aparecem no contorno do gráfico). 
As alças dos cantos permitem alterar simultaneamente a altura e a largura, 
enquanto que, as alças do meio só permitem alterar a altura ou a largura 

 

12. Depois de criar um gráfico é possível personalizar a sua formatação 

 

a) Formatar as ordenadas para apresentar apenas os valores em milhões (com duas casa 
decimais) e o símbolo M€, indicador de milhões de euros 

I. Selecionar Layout > Axes > Primary Vertical Axis > More Primary Vertical Axis 
Options… 

II. Na opção Display Units do separador Axis Options, selecionar a opção 
Millions, desmarcar a caixa de verificação Show display units label on chart 
e clicar OK 

III. Selecionar o separador  Number 
IV. Selecionar a categoria  Custom 
V. Selecionar ou definir o formato  “#.##0,00 [$M€]” 

b) Alterar os valores mínimo e máximo das ordenadas para 500 e 4000, respetivamente 
I. Selecionar Layout > Axes > Primary Vertical Axis > More Primary Vertical Axis 

Options… 
II. Selecionar o separador  Axis Options 
III. Definir  Maximum=4500000 e  Minimum=500000 

c) Alterar o título do gráfico para Vendas 2010 

I. Fazer clique sobre o título do gráfico 
II. Clique, mova o cursor e acrescente   2010 

d) Alterar o tamanho da letra do título do gráfico Vendas 2010 para  14 

I. Selecionar o título fazendo duplo clique sobre ele 
II. Utilizar as ferramentas de formatação disponíveis no separador Home 

e) Alterar o alinhamento vertical do título do eixo dos YY para  horizontal. 

I. Fazer clique sobre o título 
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II. Selecionar Format Selection no separador Layout 
III. Selecionar o separador  Alignment 
IV. Definir Text direction a Horizontal e Custom angle a 0 graus (Degrees). 

f) Alterar o título do eixo dos  YY  para  “Total (Milhões de Euros)” 

g) Alterar a cor de fundo do gráfico (Chart Area) para a cor  Orange, Accent 6, Lighter 
40% 

I. Fazer clique sobre a área do gráfico 

II. Selecionar Format Selection no separador Layout 
III. Selecionar a opção Solid fill do separador  Fill 

IV. Selecionar o botão  e escolher a cor situada na  4ª linha  e  na  última 
coluna 

h) Alterar a cor da área de desenho  (Plot Area)  para amarelo 

I. Fazer clique sobre a área de desenho 
II. Selecionar Format Selection no separador Layout 
III. Selecionar a opção Solid fill do separador  Fill 

IV. Selecionar o botão  e escolher a cor amarelo (yellow) 

i) Alterar a cor de fundo do título do gráfico Vendas 2010 para branco 

I. Fazer clique sobre o título 

II. Selecionar Format Selection no separador Layout 

III. Selecionar a opção Solid fill do separador  Fill 

IV. Selecionar o botão  e escolher a cor branco (white) 

j) Tornar o contorno do título do gráfico Vendas 2010 sombreado  (Shadow) 

I. Fazer clique sobre o título 

II. Selecionar Format Selection no separador Layout 

III. Selecionar o separador  Shadow 

IV. Selecionar o botão Presents  e escolher o primeiro botão do separador 
Outer 

k) Alterar a cor das colunas para  vermelho 

I. Fazer clique sobre uma coluna do gráfico 

II. Selecionar Format Selection no separador Layout 

III. Selecionar a opção Solid fill do separador  Fill 

IV. Selecionar o botão  e escolher a cor vermelho (red) 
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13. Para conhecer o valor exato dum dado representado no gráfico, coloque o apontador do 

rato sobre uma das colunas e espere alguns instantes. 
14. Criar um novo gráfico de colunas 3-D para comparar os desempenhos dos vendedores 

em cada trimestre 

 

a) Selecionar o bloco de células B3:F7 

b) Selecionar o separador Insert 

c) Selecionar Column > 3-D Clustered Column 
d) Definir os títulos (analogamente ao gráfico anterior): 

• Gráfico (Chart Title)  =  Vendas Trimestrais 

• Eixo dos XX  =  Trimestre 
e) Mover o gráfico para o lado direito do gráfico  Vendas 2010 
f) Redimensionar o gráfico para ficar com a mesma altura do gráfico  Vendas 2010 

15. Formatar o gráfico 

 

a) Formatar as categorias dos eixos dos ZZ para mostrar apenas os  dígitos dos 
milhares 

b) Eliminar o título do eixo dos XX 

I. Fazer clique sobre o título 
II. Premir a tecla  Delete 
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c) Alterar o alinhamento das categorias do eixo dos XX para alinhamento inclinado a -45 
graus 

d) Introduzir o título do eixo dos ZZ para  “Total (Milhares de Euros)”  e com 
alinhamento horizontal 

I. Selecionar o gráfico fazendo clique sobre a área do gráfico (Chart Area) 

II. Selecionar Axis Titles > Vertical Horizontal Axis Titles > Horizontal Title 

III. Modificar o texto “Axis Title” para “Total (Milhares de Euros)” 

e) Mudar a localização da legenda para baixo 

I. Fazer clique sobre o gráfico 
II. Selecionar o separador  Layout 
III. Selecionar a Legend > Show Legend at Bottom 

f) Alterar a perspetiva do gráfico, elevando-o a 30 graus e rodando-o a 40 graus  

I. Selecionar o gráfico fazendo clique sobre a área do gráfico  (Chart Area) 
II. Layout > 3-D Rotation 
III. Definir X a 40 e Y a 30 

16. Eliminar e introduzir uma  série de dados 

a) Eliminar a série de dados do vendedor  José Silva 

I. Selecionar a série de dados do vendedor José Silva fazendo clique sobre 
qualquer uma das suas colunas 

II. Premir a tecla  Delete 

b) Introduzir a série de dados do vendedor  José Silva 

I. Selecionar o gráfico 

II. Selecionar Design > Select Data 

III. Clicar no botão Add e selecionar a célula B6 para nome da série (Series name) 
e o bloco de células C6:F6 para valores da série (Series values) 

17. Para facilitar a comparação dos dados é conveniente reordenar as séries de dados. Para 
que as colunas do Rui Oliveira se apresentem à esquerda das do Carlos Pinto efetuar: 
I. Selecionar o gráfico 
II. Selecionar Design > Select Data 
III. Na caixa de Legend Entries (series)  selecionar  Rui Oliveira 

IV. Premir o botão Move Up  
V. Premir o botão OK 

18. Para melhor avaliar a contribuição de cada vendedor no total de vendas efetuadas pelo 
stand, deve-se criar um gráfico circular. 



Microsoft Excel  Exercício 4 
 

Formatações e Gráficos  Pág. 8/9 
 

 

a) Selecionar os blocos de células B4:B7 e G4:G7 

b) Selecionar Insert > Pie > Pie in 3D 
c) Definir o título do gráfico:   Vendedores 
d) Eliminar legenda do gráfico 
e) Selecionar Layout > Data Labels > More Data Labels Options… 
f) Selecionar Category Name (nome da categoria) e Percentage (percentagem) no 

separador Labels Options 
g) Mover o gráfico para uma zona vazia da folha de cálculo. Alterar a perspetiva do 

gráfico elevando-o a  25 graus 
h) Destacar o desempenho do vendedor  Paulo Sousa 

I. Selecione a “fatia” do gráfico referente ao vendedor em questão 
II. Fixe o botão esquerdo do rato, arraste um pouco, e verifique se está 

semelhante à figura  

19. Para analisar a variação das vendas ao longo do ano, deve-se criar um gráfico de linhas 

 
a) Selecionar os blocos de células C3:F3 e C8:F8 
b) Selecionar Insert > Line > Line 
c) Definir os títulos: 

• Gráfico (Chart Title) =  Vendas 2010 

• Eixo dos YY =  Total (Euros) 
d) Eliminar legenda 
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e) Para mover o gráfico para uma folha nova selecionar Design > Move Chart, escolher a 
opção New Sheet, definir o nome para a nova folha de gráfico como  Evolução Vendas 
2010 e clicar OK 

20. Mudar a localização do gráfico de linhas para a folha de cálculo Resultados 2010 

a) Design > Move Chart 
b) Selecionar a folha de cálculo  Resultados 2010  na caixa  As object in 

21. Gravar o livro de trabalho. 

22. Fechar o Excel 
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Pretende-se contabilizar os custos com pessoal relativos ao trabalho semanal da empresa 
“Parte Pedra, SA”. 

1. Inicie o Microsoft Excel. 

2. Abra o ficheiro de trabalho Excel_5a.xls. 

Os dados que constam no livro dizem respeito ao registo de ponto de uma semana de trabalho 
relativo à sede da empresa e das duas filiais. Os dados correspondem ao número e nome do 
funcionário, horas trabalhadas na semana em causa e custo hora. 

3. Crie um novo livro e grave-o com o nome Excel_5.xls na sua pasta pessoal. 

4. Escreva Horas na célula C1. 

5. Selecione as células A2:G2 e escreva, Número, Nome, Normais, Extras, Custo hora, 
Total e Faltas, respetivamente. 

6. Altere o nome da folha para Sede. 

7. Elimine todas as outras folhas não usadas. 

8. Crie duas cópias da folha Sede com os nomes Filial1 e Filial2. 

9. Pretende-se criar uma macro que possa formatar automaticamente os cabeçalhos. No 
livro Excel_5, na folha Sede, 

a) View > Macros > Record Macro 

 

 

b) Atribua à macro o nome     Formatar, escreva uma descrição explicativa do que 
faz a Macro   e faça  OK 

 

Nota: A partir de agora, e até que pare a gravação da macro, tudo o que fizer ficará registado 
no código da mesma. 
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10. Formate o cabeçalho de modo a apresentar um aspeto como o da figura. 

 

11. Após terminar a formatação faça: 

a) View > Macros > Stop Recording 

12. Selecione a folha Filial1 e execute a Macro Formatar. 

a) View > Macros > View Macros 

b) Escolha a macro e execute-a 

13. Repita o procedimento anterior para a folha Filial2. 

14. Pretende-se criar uma nova macro que possa automatizar a organização e tratamento dos 
dados. O objectivo é que os dados de cada funcionário fique numa linha e que seja 
calculado o total a receber por cada um, bem como o número de horas extras e o número 
de dias de falta.  

Nos dados de origem (na folha Ponto Semanal do livro Excel_5a.xls) constam o número, 
o nome, as horas trabalhadas e o valor hora de cada funcionário. O horário diário 
corresponde a 8 horas de trabalho e o semanal a 40 horas; as horas extras são pagas com 
um acréscimo de 35% e as faltas devem ser apresentadas em dias. 

15. No livro Excel_5a, na folha Ponto Semanal, selecione as células A2:A41 e copie o seu 
conteúdo para o livro Excel_5, folha Sede, célula A3. 

16. Repita a operação para cada uma das filiais copiando os dados respectivos (a começar em 
A2) para a célula A3 de cada uma das folhas. 

17. Crie uma Macro que permita organizar os dados e efectuar os cálculos pretendidos. No 
livro Excel_5, selecione a folha Sede. 

a) View > Macros > Record Macro 

b) Atribua à macro o nome     Calcular. 

c) Associe à macro a tecla de atalho Ctrl+Shift+C 

d) Escreva uma descrição explicativa do que faz a Macro   e faça  OK 

e) View > Macros 

f) Verifique se está ativa a opção Use Relative References. 

Se não estiver ative-a. 
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18. Pretende-se transpor os dados que estão em coluna para linha. Selecione as células 
A4:A7. 

Home > Copy 

19. Selecione a célula A3. 
Home > Paste > Transpose 

20. Elimine as linhas 4 a 7.  

21. Mova o conteúdo da célula D3 para a célula E3. 

22. Insira na célula D3 uma fórmula que determine as horas extras que o funcionário 
trabalhou nessa semana (só tem horas extras se trabalhou mais de 40 horas). 

23. Insira na célula F3 uma fórmula que determine o valor a receber nessa semana de acordo 
com as horas trabalhadas (as horas extras são pagas a 135%). 

24. Insira na célula G3 uma fórmula que determine os dias de falta que o funcionário teve 
nessa semana (se trabalhou menos de 40 horas). 

25. Selecione a célula A4. 

26. Termine a gravação da macro: 

a) View > Macros > Stop Recording 

27. O cursor deverá estar posicionado em A4. Faça sucessivamente Ctrl+Shift+C enquanto 
existirem dados nessa folha. 

28. Passe para a folha Filial1. Selecione a célula A3 e faça sucessivamente Ctrl+Shift 
enquanto existirem dados nessa folha. Repita o procedimento para a folha Filial2. 

29. Pretende-se calcular os totais e formatar os dados de cada uma das folhas relativas à sede 
e às filiais. Realize essa formatação e calcule os totais de acordo com as soluções. 

Soluções: 
Sede 
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Filial 1 

 

 

Filial 2 

 

 
 
 



 

 

Excel 6 – Funções, Formatações, 
Contagem e Soma condicionais e 

pesquisa por referência 
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Neste exercício pretende-se fazer, principalmente, uma análise estatística aos dados de um Centro 
de Inspecções Automóveis. Nesse sentido, execute os seguintes passos: 

1. Inicie o Microsoft Excel. Abra o livro de trabalho com o nome Ficha_06a.xls. 

2. Grave o livro de trabalho com o nome Ficha_06.xls na sua pasta pessoal ou desktop. 

3. Formate a tabela designada Inspecções Periódicas de Veículos de acordo com a figura abaixo 
apresentada. Para esse fim deve criar uma macro que realize todas as formatações conforme as 
especificações a seguir indicadas. 

a) Centrar o título da tabela ( Inspecções Periódicas de Veículos ) entre as colunas B e R. 
b) Centrar o cabeçalho da coluna B ( Ref. ) na vertical e horizontal do bloco B5:B6. 
c) Aplicar o formato anterior apenas aos seguintes cabeçalhos de coluna: Data, Duração 

(H:M), Marca, Modelo, Km, Data da Matrícula, Categoria, Idade (Anos) e Resultado. 
d) Centrar na horizontal os cabeçalhos Hora, Tarifa (€) e Deficiência. 
e) Centrar na horizontal os sub-cabeçalhos Entrada, Saída, s/IVA, c/IVA, Tipo 1, Tipo 2 e 

Tipo 3. 
f) Aplicar o estilo de letra Negrito ao título e aos cabeçalhos de coluna da tabela (B4:R6). 
g) Formatar os limites e sombreados de acordo com a figura. 
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4. Fixe o painel horizontal superior à linha 7 para manter visível o cabeçalho da tabela quando a 
folha de cálculo se movimenta na vertical. 

5. Insira a data actual na célula F2, recorrendo ao assistente de funções. 

6. Crie as fórmulas para determinar a duração de cada uma das inspecções efectuadas ( F7:F48 
), a partir das respectivas horas de entrada (coluna D) e saída (coluna E). Refira-se que cada 
linha da tabela corresponde a uma inspecção. 

7. Crie as fórmulas para determinar a idade dos veículos no dia da inspecção ( L7:L48 ), a 
partir da data de matrícula do veículo (coluna J) e da data da inspecção (coluna C).  

8. Crie as fórmulas para determinar a tarifa sem IVA aplicada a cada veículo inspeccionado ( 
M7:M48 ), de acordo com a seguinte tabela: 

Categoria Tarifa (s/ IVA) 
Ligeiro 19,95 € 
Pesado 29,93 € 

Reboques e Semi-Reboque 19,95 € 

9. Crie as fórmulas para determinar a tarifa com IVA aplicada a cada veículo inspeccionado ( 
N7:N48 ), usando a taxa de IVA guardada na célula N2. 

10. Crie as fórmulas para determinar o resultado da inspecção (Aprovado ou Reprovado) 
(R7:R48), sabendo que um veículo é reprovado sempre que se verifique, pelo menos, uma das 
seguintes condições: 

• Mais de 5 deficiências do tipo 1 

• Uma ou mais deficiências do tipo 2 ou 3 

11. Active um mecanismo que permita realçar as células da coluna Resultado cujo conteúdo é 
Reprovado, formatando a letra com a cor vermelha e o estilo Negrito. 

12. Realçar com fundo amarelo as células da coluna Idade, cujos valores se situam entre 8 e 10 
anos, inclusive. 

13. Realçar com fundo vermelho as células da coluna Km, cujo valor é igual ou superior à média 
dos quilómetros dos veículos inspeccionados: 

14. Insira um comentário na célula I5 (Km) para descrever o critério da formatação condicional 
aplicada nessa coluna. 

15. Atribua o nome Referências ao bloco de células B7:B48. Os nomes atribuídos a blocos de 
células visam, fundamentalmente, facilitar a criação e a leitura de fórmulas.  

16. Crie uma fórmula, na célula I50, para calcular o número total de inspecções registadas.  
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17. Crie os seguintes nomes de células: 

Nome Bloco de células 

Duração F7:F48 

TarifaSemIVA M7:M48 

Deficiências_T1 O7:O48 

Deficiências_T3 Q7:Q48 

18. Crie fórmulas ( I51:I61 ) para satisfazer os pedidos feitos, usando os nomes de células 
definidos anteriormente. Os resultados devem apresentar os formatos indicados na figura 
seguinte. 

19. Crie fórmulas de modo a indicar as somas parciais de facturação para Ligeiros, Pesados e 
Semi-Reboques, nas Células: H62, H63 e H64 escrever respectivamente: 

 Total recebido de Ligeiros: 
 Total recebido de Pesados: 
 Total recebido de Semi-Reboque: 

Nas células I62,I63 e I64 indicar a soma dos totais parciais de cada uma das selecções 
indicadas. 

A fórmula adaptada de =SUM.IF(categoria;"ligeiro";M7:M48) deverá permitir a visualização 
parcial de cada soma se se verificar a condição para que a soma se efectue. 

O resultado final será: 

 Total recebido de Ligeiros: 598,5 
 Total recebido de Pesados: 239,44 
 Total recebido de Semi-Reboque: 79,8 

20. Na célula H64, escreva “Referência” 

Na célula I64, Coloque o fundo a amarelo. Aí deverá escrever uma dada referência constante da 
coluna de referências. 

Na célula J65, Deve preparar a aplicação para devolver o Resultado. 
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Após efectuar uma pesquisa na tabela da dita referencia, deverá indicar o seu estado. 

Referência 2174 Reprovado 

Ou seja inserindo a referência “2174” por exemplo obtemos em J65 a informação que o veículo 
foi “reprovado”. 

USE a seguinte fórmula: 

=VLOOKUP(I65;B7:R48;17) 

21. Efectue o mesmo nas células abaixo para o seguinte. Dada a referência indicar: 

• A marca 

• O Modelo  

• O valor a Pagar 

22. Utilizando filtragem automática, faça com que sejam visíveis apenas os veículos reprovados. 

23. Crie uma macro que proceda a uma ordenação por Categoria e Data de matrícula. 

24. Crie um gráfico do tipo Pie que permita verificar a percentagem de veículos reprovados por tipo 
de deficiência. 

 



ANEXO – Tabela de funções 

  

Inglês Português Significado 
Abs Abs Devolve o valor absoluto de um número 
And E Devolve Verdadeiro se todos os argumentos forem verdadeiros 

Average Média  Devolve a média dos valores indicados 
Cos Cos Devolve o coseno de um ângulo 

Count Contar Devolve o número de células que contém números 
CountA Contar.Val Devolve o número de células que não estão vazias 

CountBlank Contar.Vazio Devolve o número de células vazias num intervalo 
CountIF ContarSe Devolve o número de células que satisfazem um determinado critério 
Cumipmt PgtoJurAcum Devolve os juros cumulativos pagos entre 2 períodos  
Cumprinc PgtoCapAcum Devolve o capital cumulativo pago num empréstimo entre 2 períodos  

Date Data Devolve o nº de série de uma data específica 
Days360 Dias360 Devolve o nº de dias entre duas datas, com base num ano de 360 dias (12 meses de 30 dias)  

False Falso Devolve o valor lógico Falso 
Hlookup ProcH Procura um valor na 1ª linha de uma tabela e devolve o valor na mesma coluna de uma linha especificada 

If Se Devolve um valor se a condição especificada for verdadeira e outro valor se for falsa 
Index Índice Devolve um valor ou a referência a um valor incluído numa tabela ou intervalo 

Isblank É.Cél.Vazia Devolve Verdadeiro se o valor especificado se referir a uma célula vazia 
Ln Ln Devolve o logaritmo natural de um número 

Lookup Proc Devolve um valor quer de um intervalo de uma linha ou de uma coluna 
Match Corresp Devolve a posição relativa de um item numa matriz que corresponde a um valor específico numa ordem determinada 
Max Máximo Devolve o valor máximo dos valores especificados  
Min Mínimo Devolve o valor mínimo dos valores especificados 

Mmult Matriz.Mult Devolve a matriz produto de 2 matrizes 
Not Não Inverte a lógica do argumento especificado 
Now Agora Devolve o nº de série da data e hora actual 
Or Ou Devolve Verdadeiro se qualquer argumento for Verdadeiro; devolve Falso se todos os argumentos forem Falso  
Pi Pi Devolve o valor de  Pi 

Pmt Pgto Devolve o pagamento periódico de uma anuidade 
Radians Radianos Converte graus em radianos 

Sin Sen Devolve o seno de um ângulo 
Sqrt RaizQ Devolve a raiz quadrada de um número 
Sum Soma Efectua o somatório dos valores indicados 
SumIf SomaSe Adiciona as células especificadas por um determinado critério 

SumProduct SomarProduto Multiplica os elementos correspondentes das matrizes, e devolve a soma destes produtos 
Tan Tan Devolve a tangente de um ângulo 

Today Hoje Devolve o número de série da data corrente 
Transpose Transpor Devolve uma área vertical de células como área horizontal e vice-versa 

True Verdadeiro Devolve o valor lógico Verdadeiro 
Vlookup ProcV Procura um valor na 1ª coluna duma tabela (ordem ascendente), e devolve um valor na mesma linha de uma dada coluna 


